Author Topic: wipers will not park  (Read 369 times)

Offline jimmycuda71

  • Jr. Member
  • **
  • Posts: 186
  • The Money Pit
wipers will not park
« on: February 14, 2018 - 03:47:20 pm »
Hello all,

A few months ago I washed my 73 Cuda and when I went to use the wipers they went crazy.  At first they would not turn off. I assumed that I had gotten something wet. So I tried it the next day and they shutoff but would no longer park. Like I said that was several months ago. I tried them yesterday and still wont park. You would think if I got something wet it would have dried out by now. Any Ideas?
Thanks Jimmycuda71




Offline DAYLEY/CHALLENGER

  • Resident
  • *****
  • Posts: 3150
  • Still My Inspiration..1971, Rockingham, Nc
Re: wipers will not park
« Reply #1 on: February 14, 2018 - 05:34:15 pm »
I had that very problem when I bought my new 70 Challenger way back in 1970....The dealer of course fixed it but I do not know what they did...........just saying, the issue is not new............Good luck.........
Dave or David

Offline Fern

  • Full Member
  • ***
  • Posts: 626
Re: wipers will not park
« Reply #2 on: February 14, 2018 - 08:04:26 pm »
Sounds like a grounding problem.
Check the ground at the switch, tie a wire from the back of switch and ground it to the metal on dash.

Online 70chall440

  • Resident
  • *****
  • Posts: 4837
Re: wipers will not park
« Reply #3 on: February 15, 2018 - 01:11:10 pm »
2 or 3 speed? IMO the 3 speed is easier to diagnose and repair but I am pretty certain both can be repair.
Current Mopar
70 Challenger RT 440-6, 73 Cuda (under const)
05 Durango, 99 Dakota, 01 Ram 4x4, 14 2500 4X4, 10 PCP Challenger RT, 01 Viper GTS ACR, 52 B3B w/330 Desoto Hemi, 70 Hemi RR, 61 Jeep FC170
Past Mopars
9 x Challengers. AAR Cuda, 4 RR, 2 GTX, 4 Chargers, etc... (too many to list)