Cuda-Challenger.com

2009-20xx Challenger => New Challenger General => Topic started by: 7212Mopar on October 29, 2018 - 03:51:38 pm

Title: 6 Speed Transmission
Post by: 7212Mopar on October 29, 2018 - 03:51:38 pm
My SRT developed some drive line noises over a year ago. It comes and goes and it sounded like a scraping noise something internal to the trans. It usually comes after a hard right turn and then disappear after a hard left. It droves me nuts but too lazy to deal with. At first I thought it might be a broken motor mount but that they checked out fine. so I thought it must be a broken trans mount. Finally a few weeks ago I ordered a new trans mount and then get under the car. It turns out that the trans mount was also not broken. However, in the process I discovered the aluminum cradle that holds the trans mount can move a little relative to the body even all the bolts are tighten. The way Dodge did it for whatever reason was to have the four bolt holes at the cradle to be at least twice bigger than the bolts. I ended up installing the new trans mount, added sleeves made from some 5/16" fuel hose over the bolts before reassemble everything. I had to muscle the trans a little to line up all the bolt holes. All is good now and I am happy to report that the noise went away and the car feels more solid now and is a lot of fun to drive. BTW, I do have the Barton shifter installed in the car.
Title: Re: 6 Speed Transmission
Post by: 70chall440 on October 29, 2018 - 05:47:33 pm
Outstanding information, thanks for sharing it. Most people do not bother to post things that went right.
Title: Re: 6 Speed Transmission
Post by: JS29NOB on December 01, 2018 - 08:44:10 pm
What?  Sometimes things CAN go right?  Amazing.
Title: Re: 6 Speed Transmission
Post by: Beekeeper on December 01, 2018 - 10:32:47 pm
I wonder what reason the designers had for doing that. Good for you tracking it down and figuring out a sensible solution!