Cuda-Challenger.com

Chryco's Tech Shop => Engine & Go Fast Goodies => Topic started by: cv70chall on August 03, 2018 - 02:29:33 pm

Title: Oil Pressure Question
Post by: cv70chall on August 03, 2018 - 02:29:33 pm
Recently installed an oil pressure gauge. Has worked well. Averages about 30-40psi at idle. Ramps up to 40-60psi during driving. I've recently noticed that the pressure has been running higher while driving- say, around 70-80psi, although it drops to 30-40psi at idle.
Does this indicate I might need an oil change? I barely drive the car- maybe 100 miles a month.

?
Title: Re: Oil Pressure Question
Post by: 70chall440 on August 03, 2018 - 03:04:03 pm
That shouldn't indicate a need to change the oil. Oil viscosity can have an effect on pressure but dirty v clean of the same oil typically does not show a huge difference. Is this a mechanical or electrical gauge? Either way, I would suspect the gauge or sending unit. That said, you can always change the oil and see what happens to the pressure, can't hurt.
Title: Re: Oil Pressure Question
Post by: 73440 on August 03, 2018 - 11:03:01 pm
Time of day when driving , due to viscosity and heat , will affect pressure reading.
7 am I will have almost 40 psi for first mile or so, then settles down to 25 psi rest of day.
This is iin daily driver with 400,000 miles , so your readings will be different.
Title: Re: Oil Pressure Question
Post by: 70chall440 on August 03, 2018 - 11:14:39 pm
Time of day when driving , due to viscosity and heat , will affect pressure reading.
7 am I will have almost 40 psi for first mile or so, then settles down to 25 psi rest of day.
This is iin daily driver with 400,000 miles , so your readings will be different.

This situation is normal, the condition being described in the beginning isnt. It was running 40-60 cold and now is running 70-80 which to me indicates a gauge or sending unit issue; either it was stuck originally now has free'd up or it was correct originally and now the diaphragm or spring has weakened.
Title: Re: Oil Pressure Question
Post by: 73440 on August 04, 2018 - 07:40:12 pm
Ah, I see said the blind man, I got it backwards when reading the first post.
Title: Re: Oil Pressure Question
Post by: 70chall440 on August 05, 2018 - 12:32:37 pm
I do it all the time..  :banghead:
Title: Re: Oil Pressure Question
Post by: cv70chall on August 21, 2018 - 09:02:03 pm
So, this is a mechanical gauge. I checked the line for kinks, etc and found none. The Engine has maybe 67k on it total before I installed it. All I've done is new cam, new heads, gaskets, water and oil pump- and this was nearly 3 years ago.
I drive the car maybe 30 to 80 miles a month..Yes...a month.
I've changed the oil twice since installing it.
Could I be using the wrong oil?
I'm currently using 10W40. It's in Florida.
Title: Re: Oil Pressure Question
Post by: 70chall440 on August 22, 2018 - 11:47:38 am
Swap the gauge.