Author Topic: Really weird turn signal issue  (Read 270 times)

Offline marcus

  • Jr. Member
  • **
  • Posts: 45
Really weird turn signal issue
« on: August 11, 2017 - 08:21:33 pm »
Just replaced the turn signal switch assembly and the problem is still there. It's a weird one.

Only happens at dark when all lights are on.
After about 15-20 minutes of driving the left turn signal indicator starts to dimly turn on/flicker.
Flashing the left turn signal indicator makes it go away.
What could be causing an issue like this?
Here is a video of it happening
https://youtu.be/7tdrqJdRfhA




Offline Bullitt-

  • Permanent Resident
  • *******
  • Posts: 12168
  • Better Things To Come Member Since 2/16/06
Re: Really weird turn signal issue
« Reply #1 on: August 11, 2017 - 08:58:14 pm »
Never heard of such but most issues of this nature are due to poor grounds...
My first instinct is to suspect the flasher .. power has to discharge through the flasher if I understand the system
Wade  73 Rallye 340..'77 Millennium Falcon...13 R/T Classic   Huntsville, AL
Screwed by Photobucket!

Offline GoodysGotaCuda

  • Sr. Resident
  • ******
  • Posts: 5262
Re: Really weird turn signal issue
« Reply #2 on: August 11, 2017 - 10:14:02 pm »
I'd have to investigate the ground circuits as well. I wouldn't be surprised if a poor chassis ground on a light is somehow backfeeding through the other element to find ground at the fender indicator [or something like that].
:working: Build Page: Goody's 'Cuda Build Page :working:

2016 Subaru WRX
2016 BMW X1
1976 Dodge Warlock
1972 Barracuda - 5.7 Hemi + T56 Magnum - In progress

Wheel & Tire Specs:Link
Aftermarket Gauges:Link


Offline TelisSE440

  • Sr. Member
  • ****
  • Posts: 1743
Re: Really weird turn signal issue
« Reply #3 on: August 12, 2017 - 01:24:20 am »
I'd have to investigate the ground circuits as well. I wouldn't be surprised if a poor chassis ground on a light is somehow backfeeding through the other element to find ground at the fender indicator [or something like that].

 :iagree: Check the left aluminum housing of the front turn amber light, clean it thouroughly from rust dirt etc and tight it firmly on to the chassis, check by using a light tester grounding the grey aluminum case. If this case doesn't ground to the chassis or is rusted/dirty then a current feedback occurs targeting your turn signal indicators. Hope i helped

Offline garity

  • Jr. Member
  • **
  • Posts: 31
  • 74 Challenger
Re: Really weird turn signal issue
« Reply #4 on: August 12, 2017 - 02:10:37 am »
The flasher circuit shares a fuse with the radio and the neutral safety switch. Maybe try disconnecting the radio power and then the connector to the neutral safety switch/backup light near the wiper motor area under the front hood. The exhaust manifold can burn the insulation on the wires to the neutral safety switch harness if it is too close to it. Something to try anyways.

Offline marcus

  • Jr. Member
  • **
  • Posts: 45
Re: Really weird turn signal issue
« Reply #5 on: August 12, 2017 - 01:35:06 pm »
:iagree: Check the left aluminum housing of the front turn amber light, clean it thouroughly from rust dirt etc and tight it firmly on to the chassis, check by using a light tester grounding the grey aluminum case. If this case doesn't ground to the chassis or is rusted/dirty then a current feedback occurs targeting your turn signal indicators. Hope i helped

Ahhhhhhhhhhh!! This explains things! I have noticed during the day that the left front fender turn signal indicator sometimes does not flash while the others do. So I never put 2 and 2 together.   :eek4:

What your saying makes perfect sense. During the day the indicator works intermittently (due to poor grounding) and during the night I can see current feedback going though it (due to the same poor grounding).   I will inspect and clean all the grounds today. Thanks for the tips!

Offline DAYLEY/CHALLENGER

  • Resident
  • *****
  • Posts: 3101
  • Still My Inspiration..1971, Rockingham, Nc
Re: Really weird turn signal issue
« Reply #6 on: August 12, 2017 - 10:38:01 pm »
By all means check the grounds...  And the video, it took me 15 minutes to get back to the thread.  Just can't watch just one! :bigsmile:
Dave or David

Offline marcus

  • Jr. Member
  • **
  • Posts: 45
Re: Really weird turn signal issue
« Reply #7 on: August 13, 2017 - 02:11:18 am »
Fixed! Video details here-
https://youtu.be/jqOyQpDVodc

Thanks again!

Offline TelisSE440

  • Sr. Member
  • ****
  • Posts: 1743
Re: Really weird turn signal issue
« Reply #8 on: August 14, 2017 - 09:18:43 am »
Fixed! Video details here-
https://youtu.be/jqOyQpDVodc

Thanks again!

Glad you sorted it out!  :thumbsup: