Author Topic: My first Mopar! Craigslist find.  (Read 21528 times)

Offline 734406pk

  • Andy
  • Sr. Member
  • ****
  • Posts: 1690
Re: My first Mopar! Craigslist find.
« Reply #15 on: May 19, 2015 - 08:55:32 pm »
I had Cragar Super Trick wheels on my 70 TA years ago (mid 80's). Brings back memories! Looks very cool! :thumbsup:
1973 Challenger 440 6 pack auto 3.91 rear
2012 Dodge Ram 3500 dually 6.7 Cummins Fleece EFI Live
1973 Challenger 318 2bbl auto 2.73 rear 22.5 mpg RIP
1970 Challenger TA 340 4bbl auto-Sold and sad
1999 Dodge Ram 3500 dually 5.9 Cummins Fleece tuned VGT-sold
1995 Kawasaki ZX1100E & still alive




Offline ed-pv

  • Jr. Member
  • **
  • Posts: 160
Re: My first Mopar! Craigslist find.
« Reply #16 on: May 20, 2015 - 09:20:48 am »
Front Lower Control Arm bushings are toast...first order of business is front suspension rebuild.

My plan of attack:

Front Suspension rebuild/upgrade
upgrade to power disc brakes
rebuild carb, new fuel filter, ,new plugs, plug wires, clean out fuel pump, compression test motor, set timing (Car has not run in about a year)  Car starts, but stumbles.
Flush Cooling system, possibly rebuild radiator
Change out seats (current seats are from a mid 90's Camaro)
Change out tire/wheels
If motor does not need major work...paint and body :)

Offline ed-pv

  • Jr. Member
  • **
  • Posts: 160
Re: My first Mopar! Craigslist find.
« Reply #17 on: May 21, 2015 - 03:02:07 pm »
Bringing her home!

« Last Edit: May 21, 2015 - 03:04:58 pm by ed-pv »


Offline ed-pv

  • Jr. Member
  • **
  • Posts: 160
Re: My first Mopar! Craigslist find.
« Reply #18 on: May 21, 2015 - 03:11:09 pm »
Got it home, replaced the battery, checked fluids, plugs wires, fuel and tried to fire it up.  It started, but would not stay running.  Suspect the carb.  Car had a new Quickfuel carb in the trunk so I pulled the AED and put the Quickfuel on the car and it started and ran pretty good!

« Last Edit: May 21, 2015 - 03:14:49 pm by ed-pv »

Offline dfrazz

  • 1970 Cuda - 1968 Charger
  • Resident
  • *****
  • Posts: 4076
Re: My first Mopar! Craigslist find.
« Reply #19 on: May 21, 2015 - 04:20:12 pm »
Got it home, replaced the battery, checked fluids, plugs wires, fuel and tried to fire it up.  It started, but would not stay running.  Suspect the carb.  Car had a new Quickfuel carb in the trunk so I pulled the AED and put the Quickfuel on the car and it started and ran pretty good!

Where's the video?   :dunno: :clueless: :hyper:

Offline ed-pv

  • Jr. Member
  • **
  • Posts: 160
Re: My first Mopar! Craigslist find.
« Reply #20 on: May 21, 2015 - 09:32:51 pm »
Not sure how to post a video, but here is a link:  https://vimeo.com/128549465  Very healthy cam :)
« Last Edit: May 21, 2015 - 09:36:06 pm by ed-pv »

Offline ed-pv

  • Jr. Member
  • **
  • Posts: 160
Re: My first Mopar! Craigslist find.
« Reply #21 on: May 21, 2015 - 09:44:36 pm »
Did a radiator flush, but radiator looks terrible inside.  Going to replace tomorrow.

Offline ed-pv

  • Jr. Member
  • **
  • Posts: 160
Re: My first Mopar! Craigslist find.
« Reply #22 on: May 22, 2015 - 06:45:49 am »
Changed out the water pump and water pump housing while I was working on the radiator.

Offline ed-pv

  • Jr. Member
  • **
  • Posts: 160
Re: My first Mopar! Craigslist find.
« Reply #23 on: May 27, 2015 - 04:24:26 pm »
I was able to work on the Challenger yesterday.  Radiator, fans, water pump housing, water pump, thermostat all in and car runs really well now!  It still gets up to 200 deg in 90 deg Florida weather.  I am used to my big blocks (454, 428, 390) running around 180 max.  Is this the normal temp for a 440?  THANKS!


Offline roadman5312

  • Sr. Resident
  • ******
  • Posts: 5742
Re: My first Mopar! Craigslist find.
« Reply #24 on: May 27, 2015 - 04:31:49 pm »
Did ya make sure to clean the love bugs out of the grill.   :smilielol:  Where abouts in Fl. ? 

Offline ed-pv

  • Jr. Member
  • **
  • Posts: 160
Re: My first Mopar! Craigslist find.
« Reply #25 on: May 27, 2015 - 04:49:08 pm »
New radiator so clear of love bugs :)  In Ponte Vedra Beach just east of Jacksonville.

Offline roadman5312

  • Sr. Resident
  • ******
  • Posts: 5742
Re: My first Mopar! Craigslist find.
« Reply #26 on: May 27, 2015 - 05:02:06 pm »
If your maintaining 200 degrees thats not to bad.  Experimenting with diff thermostats, fan on/off timing, distributor timing can help. You ever get down Orlando/Kissimmee area give us a shout.   :cheers:

Offline anlauto

  • Permanent Resident
  • *******
  • Posts: 12346
  • I'm Alan G...I'm a Mopar Addict
    • Alan Gallant Automotive Restoration
Re: My first Mopar! Craigslist find.
« Reply #27 on: May 27, 2015 - 05:03:45 pm »
Is there any part number on the old rad's top tank ?
I've taught you everything you know.....but I haven't taught you everything I know !
www.alangallantautomotiverestoration.com

Offline roadman5312

  • Sr. Resident
  • ******
  • Posts: 5742
Re: My first Mopar! Craigslist find.
« Reply #28 on: May 27, 2015 - 05:08:19 pm »
Is there any part number on the old rad's top tank ?
                         He probably don't ship Alan.   :roflsmiley:   :smilielol:    :stirpot:

Offline CudamanTom

  • Resident
  • *****
  • Posts: 2717
Re: My first Mopar! Craigslist find.
« Reply #29 on: May 27, 2015 - 07:45:02 pm »
                         He probably don't ship Alan.   :roflsmiley:   :smilielol:    :stirpot:

 :smilielol: :roflsmiley:  :poopoke:
1971 Cuda Vert 440-833 - (clone)
1971 Cuda 440-727 - (clone)


Because I like it fast!!!