Author Topic: Coil voltage  (Read 360 times)

Offline RedKing7

  • Jr. Member
  • **
  • Posts: 13
Coil voltage
« on: June 03, 2017 - 06:14:27 pm »
Any one know what the voltage drop is suppose to be across the coil on a '72 340 with electronic ignition?




Offline dodj

  • Sr. Resident
  • ******
  • Posts: 6179
Re: Coil voltage
« Reply #1 on: June 03, 2017 - 09:36:53 pm »
Starting,  close to 12. Running,  about 9.
Scott
1973 Challenger  440 4 spd 
2007.5 3500 6.7 Cummins Diesel, Anarchy tuned.
Good friends don't let friends do stupid things. ........alone.

Offline RedKing7

  • Jr. Member
  • **
  • Posts: 13
Re: Coil voltage
« Reply #2 on: June 03, 2017 - 10:22:39 pm »
So, I have 4 with the ignition switch on.  Won't turn over.  Know the battery is weak.  Am going to charge over night.  Could this be a voltage regulator problem or something else?


Offline dodj

  • Sr. Resident
  • ******
  • Posts: 6179
Re: Coil voltage
« Reply #3 on: June 04, 2017 - 09:01:00 am »
Regulator can only be an issue after starting. 
Low voltage with the ign sw on its likely just battery.
Scott
1973 Challenger  440 4 spd 
2007.5 3500 6.7 Cummins Diesel, Anarchy tuned.
Good friends don't let friends do stupid things. ........alone.

Offline RedKing7

  • Jr. Member
  • **
  • Posts: 13
Re: Coil voltage
« Reply #4 on: June 04, 2017 - 06:24:31 pm »
Thanks Scott.  I think you are right.  Battery is 2 years old, but won't hold a charge.  Will try and replace this week.

Offline RedKing7

  • Jr. Member
  • **
  • Posts: 13
Re: Coil voltage
« Reply #5 on: June 08, 2017 - 10:25:19 pm »
Old battery had no amps.  New battery has plenty, but still won't spark.  Have 5 volts across coil (< 1 year old).  Have 12 volts across ballast resister and coil.  No spark when pull coil wire off of distributor.  Could this be bad resister?  It is the original.

Offline mopar70maniac

  • Jr. Member
  • **
  • Posts: 33
Re: Coil voltage
« Reply #6 on: October 11, 2017 - 03:27:04 pm »
hello red king, was wondering what became of your ignition issue? did you get it figured out? seems a common problem as I too have similar issues. thinkin about converting to points distributor