Barracuda Challenger Forum

Author Topic: Hydroboost Brake System  (Read 306 times)

Offline George72Cuda

  • Jr. Member
  • **
  • Posts: 29
Hydroboost Brake System
« on: May 13, 2017 - 08:56:24 am »
Has anyone installed a Hydroboost brake system on the firewall and used original brake support system on the interior ?  I'm having problems getting the two items hooked up.   Thanks




Offline Rolling_Thunder

  • Jr. Member
  • **
  • Posts: 185
  • only 2 things get my attention, gas and perfume
Re: Hydroboost Brake System
« Reply #1 on: May 30, 2017 - 10:17:21 pm »
I used a hydroboost unit I pieced together on my 68 Charger - what problem are you having ?
2013 Dodge Challenger R/T - 5.7L / 6-speed

1973 Dodge Challenger Rallye - 340 / Auto

1968 Dodge Charger - 6.1L / 6-speed

1964 Dodge Polara - 440 8-71 / 4-speed

Offline jordan

  • Full Member
  • ***
  • Posts: 601
  • no replacement for displacement
Re: Hydroboost Brake System
« Reply #2 on: May 30, 2017 - 11:35:43 pm »
I used Hydrotech and I remember having to remove all the linkage at the top of the brake pedal and used the top of the brake pedal directly connected to the push rod. 
"Don't brake until you see God!"


Online 7212Mopar

  • Full Member
  • ***
  • Posts: 582
Re: Hydroboost Brake System
« Reply #3 on: May 31, 2017 - 02:25:36 am »
Hydratech kit comes with a bullet piece that threads to the push rod of the unit. That bullet piece is then bolt to the top of the brake pedal per their instruction. I got all the parts and will be doing the install in the next few weeks.
1973 Challenger Rallye, AT with 1971 340
2012 Challenger SRT8 392 YJ,  6 spd

Offline George72Cuda

  • Jr. Member
  • **
  • Posts: 29
Re: Hydroboost Brake System
« Reply #4 on: June 02, 2017 - 04:14:20 pm »
Thanks guys. I finally figured it out. I did have to remove several pieces on the OE brake support. Works fine now.